MediaServicesのコンパイルエラー

投稿者: | 2014年2月15日

WindowsAzure MediaServicesの現在の最新バージョンを利用するとコンパイルエラーが発生します。

Microsoft.WindowsAzure.MediaServicesの3.0.0をNugetで取得すると関連として落ちてくる下記の参照プロパティのバージョンに問題があります。

 

Microsoft.Data.Edm 5.6

Microsoft.Data.OData 5.6

 

上記の参照プロパティはOAuth系のものなのですが、MediaServicesで利用する場合はバージョンを5.5にしないとコンパイルが通りません。

Nugetで一緒に落としてくるなよっ!!とつっこみたくなりました。

ここら辺解決してくれないかとMSに切に願うものであります。

 

Nugetで取得するサンプルコードを記載しておきますね。

※バージョン指定していないので常に最新版が落ちてきます。

 

 

Nuget後、参照設定を5.5に変えます。

これでコンパイルが通るはずです。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA